Finalmente! Netflix para Raspberry Pi 3

Share

A tempos que este, sem dúvida era o maior sonho de todo dono da plaquinha que a utiliza como media center. O Netflix não era compatível com o Raspberry devido a biblioteca de desencriptação DRM não ser compatível com a arquitetura ARM do Raspberry. Mas para o Chromebook ela é compatível e ele utiliza ARM. Então foi questão de tempo um usuário da grande comunidade trazer a versão do Chromium com a tal biblioteca para o Raspberry, e esse dia chegou!

Tudo que você tem que fazer é baixar o Chromium com a biblioteca necessária e instalar:

Baixe o arquivo chromium-browser_56.0.2924.84-0ubuntu0.14.04.1.1011.deb e simplesmente instale.

Ou execute os comandos abaixo no terminal.

$ wget https://github.com/kusti8/chromium-build/releases/download/netflix-1.0.0/chromium-browser_56.0.2924.84-0ubuntu0.14.04.1.1011.deb

$ sudo dpkg -i chromium-browser_56.0.2924.84-0ubuntu0.14.04.1.1011.deb

Após a instalação no menu Internet irá aparecer o atalho “Netflix-Launcher”. Ele irá iniciar o Chromium já na página do Netflix e com o User-agent apropriado.

Netflix no Raspberry Pi 3

Iniciar essa página e logar era a parte fácil já que uma mudança no User-agent o fazia anteriormente.

Mas rodar o vídeo que é onde o plugin entra em cena somente agora que consegui:

Netflix no Raspberry Pi 3
Se não acredita, veja então este vídeo:

Via Everpi.

6 opiniões sobre “Finalmente! Netflix para Raspberry Pi 3

  • julho 19, 2017 em 8:14 pm
    Permalink

    Pra mim deu um erro:
    sudo dpkg -i chromium-browser_56.0.2924.84-0ubuntu0.14.04.1.1011.deb.1
    (Lendo banco de dados … 123130 ficheiros e directórios actualmente instalados.)
    A preparar para desempacotar chromium-browser_56.0.2924.84-0ubuntu0.14.04.1.1011.deb.1 …
    A descompactar chromium-browser (56.0.2924.84-0ubuntu0.14.04.1.1011) sobre (56.0.2924.84-0ubuntu0.14.04.1.1011) …
    dpkg: problemas com dependências impedem a configuração de chromium-browser:
    chromium-browser depende de libxcb-image0; porém:
    Pacote libxcb-image0 não está instalado.

    dpkg: erro ao processar o pacote chromium-browser (–install):
    problemas de dependência – deixando desconfigurado
    A processar ‘triggers’ para hicolor-icon-theme (0.13-1) …
    A processar ‘triggers’ para man-db (2.7.0.2-5) …
    A processar ‘triggers’ para gnome-menus (3.13.3-6) …
    A processar ‘triggers’ para desktop-file-utils (0.22-1) …
    A processar ‘triggers’ para mime-support (3.58) …
    Erros foram encontrados durante o processamento de:
    chromium-browser

    Resposta
    • julho 19, 2017 em 8:26 pm
      Permalink

      Consegui fazer funcionar fazendo o seguinte:
      sudo apt-get install libxcb-image0
      Depois dei o segundo comando novamente e funcionou. Valeu!

      Resposta
      • julho 21, 2017 em 3:48 pm
        Permalink

        Hehe, mexer com linux é assim mesmo. Você pesquisa a mensagem de erro e encontra a solução.
        Provável que a versão do SO que estava usando não era a mais recente, por isso deu que não tinha essa dependência.

        Resposta
  • setembro 4, 2017 em 5:54 pm
    Permalink

    Sabe dizer se é possível instalar o Chromium com o Kodi para poder utilizar o Netflix ou somente com Linux em xWindow?

    Valeu!

    Resposta
  • Pingback: Netflix para Raspberry Pi 3 - Projetos para Raspberry PI

  • maio 17, 2018 em 3:35 pm
    Permalink

    Essa versão chromium-browser_56.0.2924.84 está desatualizada, e quando atualiza para de funcionar
    Tem como modifica a versão atual 60?

    Resposta

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *